Back to overview
Resolved

ShipStation App is down

Jul 13, 2026 at 3:49am UTC
Affected services
ShipStation App

Resolved
Jul 13, 2026 at 5:14pm UTC

ShipStation App recovered.

Updated
Jul 13, 2026 at 5:10pm UTC

ShipStation App is degraded.

Updated
Jul 13, 2026 at 5:05pm UTC

ShipStation App recovered.

Created
Jul 13, 2026 at 3:49am UTC

ShipStation App is degraded.