Back to overview
Resolved
Klaviyo App, Klaviyo Campaign Email Sending, and 1 other service are down
Jul 7, 2026 at 3:34pm UTC
Affected services
Klaviyo App
Klaviyo Campaign Email Sending
Klaviyo Flow Email Sending
Resolved
Jul 7, 2026 at 4:51pm UTC
Klaviyo Campaign Email Sending and Klaviyo Flow Email Sending recovered.
Affected services
Updated
Jul 7, 2026 at 4:01pm UTC
Klaviyo App recovered.
Affected services
Created
Jul 7, 2026 at 3:34pm UTC
Klaviyo App, Klaviyo Campaign Email Sending, and Klaviyo Flow Email Sending are degraded.
Affected services