Back to overview
Resolved

Klaviyo Email Deliverability and Cloudflare Network are down

Jul 2, 2026 at 12:24am UTC
Affected services
Klaviyo Email Deliverability
Cloudflare Network

Resolved
Jul 2, 2026 at 2:34pm UTC

Klaviyo Email Deliverability recovered.

Updated
Jul 2, 2026 at 12:18pm UTC

Klaviyo Email Deliverability is degraded.

Updated
Jul 2, 2026 at 10:20am UTC

Cloudflare Network recovered.

Created
Jul 2, 2026 at 12:24am UTC

Cloudflare Network is degraded.