Back to overview
Degraded
ShipStation App and ShipStation Carrier USPS (Stamps.com) are down
May 22, 2026 at 4:14am UTC
Affected services
ShipStation App
ShipStation Carrier USPS (Stamps.com)
Resolved
May 22, 2026 at 4:19am UTC
ShipStation Carrier USPS (Stamps.com) recovered.
Affected services
Updated
May 22, 2026 at 4:17am UTC
ShipStation App recovered.
Affected services
Created
May 22, 2026 at 4:14am UTC
ShipStation App and ShipStation Carrier USPS (Stamps.com) are degraded.
Affected services