ShipStation App, ShipStation Carrier USPS (Stamps.com), and 2 other services are down
Resolved
Apr 9, 2026 at 6:41pm UTC
Incident Resolved
Affected services
Updated
Mar 21, 2026 at 8:49am UTC
Cloudflare Network recovered.
Affected services
Updated
Mar 20, 2026 at 11:10am UTC
Cloudflare Network is degraded.
Affected services
Updated
Mar 20, 2026 at 10:24am UTC
ShipStation Carrier USPS (Stamps.com) recovered.
Affected services
Updated
Mar 20, 2026 at 10:21am UTC
ShipStation Carrier USPS (Stamps.com) is degraded.
Affected services
Updated
Mar 18, 2026 at 11:06pm UTC
Cloudflare Load Balancing & Monitoring recovered.
Affected services
Updated
Mar 18, 2026 at 10:11pm UTC
Cloudflare Load Balancing & Monitoring is degraded.
Affected services
Updated
Mar 17, 2026 at 3:31am UTC
ShipStation Slowness
Investigating - ShipStation is aware of the technical issues impacting the ShipStation Platform with batches and allocation. They advise they are actively working to resolve this issue.
Affected services
Created
Mar 16, 2026 at 3:32pm UTC
ShipStation App is degraded.
Affected services