Back to overview
Degraded

ShipStation Carrier UPS is down

Feb 03, 2026 at 10:17pm UTC
Affected services
ShipStation Carrier UPS

Resolved
Feb 03, 2026 at 10:21pm UTC

ShipStation Carrier UPS recovered.

Created
Feb 03, 2026 at 10:17pm UTC

ShipStation Carrier UPS is degraded.