Back to overview
Degraded

ShipStation App is down

Jan 23, 2026 at 06:28pm UTC
Affected services
ShipStation App

Resolved
Jan 23, 2026 at 07:25pm UTC

ShipStation App recovered.

Created
Jan 23, 2026 at 06:28pm UTC

ShipStation App is degraded.