Back to overview
Degraded

ShipStation App, ShipStation Carrier USPS (Stamps.com), and 1 other service are down

Dec 19 at 05:20am CST
Affected services
ShipStation App
ShipStation Carrier USPS (Stamps.com)
Cloudflare Network

Resolved
Dec 20 at 11:36am CST

ShipStation App recovered.

Updated
Dec 20 at 11:32am CST

ShipStation App is degraded.

Updated
Dec 20 at 08:59am CST

Cloudflare Network recovered.

Updated
Dec 19 at 10:25am CST

ShipStation Carrier USPS (Stamps.com) recovered.

Updated
Dec 19 at 10:22am CST

ShipStation Carrier USPS (Stamps.com) is degraded.

Updated
Dec 19 at 09:07am CST

Cloudflare Network is degraded.

Updated
Dec 19 at 07:59am CST

Cloudflare Network recovered.

Created
Dec 19 at 05:20am CST

Cloudflare Network is degraded.