Back to overview
Degraded
ShipStation App is down
Dec 05, 2025 at 09:09am UTC
Affected services
ShipStation App
Resolved
Dec 05, 2025 at 09:32am UTC
ShipStation App recovered.
Affected services
Created
Dec 05, 2025 at 09:09am UTC
ShipStation App is degraded.
Affected services