Klaviyo Signup Forms, Klaviyo Campaign Email Sending, and 4 other services are down
Resolved
Nov 03 at 11:05am CST
Cloudflare DNS Root Servers recovered.
Affected services
Updated
Nov 03 at 11:02am CST
Cloudflare DNS Root Servers is degraded.
Affected services
Updated
Nov 03 at 09:16am CST
Klaviyo Signup Forms, Klaviyo Campaign Email Sending, Klaviyo Email Deliverability, and 2 other resources recovered.
Affected services
Created
Nov 03 at 09:12am CST
Klaviyo Signup Forms, Klaviyo Campaign Email Sending, Klaviyo Email Deliverability, and 2 other resources are degraded.
Affected services