Back to overview
Degraded
ShipStation App is down
Oct 10 at 12:37pm CDT
Affected services
ShipStation App
Resolved
Oct 10 at 06:03pm CDT
ShipStation App recovered.
Affected services
Created
Oct 10 at 12:37pm CDT
ShipStation App is degraded.
Affected services