Back to overview
Degraded

ShipStation Carrier UPS is down

Oct 08, 2025 at 05:02pm UTC
Affected services
ShipStation Carrier UPS

Resolved
Oct 08, 2025 at 05:06pm UTC

ShipStation Carrier UPS recovered.

Created
Oct 08, 2025 at 05:02pm UTC

ShipStation Carrier UPS is degraded.