Transactional Email API, ShipStation App, and 3 other services are down
Resolved
Sep 17, 2025 at 09:35pm UTC
Transactional Email API recovered.
Affected services
Updated
Sep 17, 2025 at 09:10pm UTC
ShipStation Carrier USPS (Stamps.com) and ShipStation Carrier UPS recovered.
Affected services
Updated
Sep 17, 2025 at 09:07pm UTC
ShipStation Carrier UPS is degraded.
Affected services
Updated
Sep 17, 2025 at 09:07pm UTC
ShipStation Carrier USPS (Stamps.com) is degraded.
Affected services
Updated
Sep 17, 2025 at 06:26pm UTC
ShipStation Carrier USPS (Stamps.com) recovered.
Affected services
Updated
Sep 17, 2025 at 06:22pm UTC
ShipStation Carrier USPS (Stamps.com) is degraded.
Affected services
Updated
Sep 16, 2025 at 09:25pm UTC
Klaviyo Flow Email Sending recovered.
Affected services
Updated
Sep 16, 2025 at 09:06pm UTC
Klaviyo Flow Email Sending is degraded.
Affected services
Updated
Sep 10, 2025 at 03:20pm UTC
ShipStation App recovered.
Affected services
Updated
Sep 10, 2025 at 03:17pm UTC
ShipStation App is degraded.
Affected services
Created
Sep 09, 2025 at 09:59pm UTC
Transactional Email API is degraded.
Affected services