Back to overview
Degraded

ShipStation Carrier UPS is down

Sep 08, 2025 at 02:03pm UTC
Affected services
ShipStation Carrier UPS

Resolved
Sep 08, 2025 at 02:06pm UTC

ShipStation Carrier UPS recovered.

Created
Sep 08, 2025 at 02:03pm UTC

ShipStation Carrier UPS is degraded.