Back to overview
Degraded

ShipStation Carrier UPS is down

Aug 11, 2025 at 03:22pm UTC
Affected services
ShipStation Carrier UPS

Resolved
Aug 11, 2025 at 03:26pm UTC

ShipStation Carrier UPS recovered.

Created
Aug 11, 2025 at 03:22pm UTC

ShipStation Carrier UPS is degraded.