Back to overview
Degraded
ShipStation App, ShipStation Carrier FedEx, and 1 other service are down
Jul 25, 2025 at 04:38pm UTC
Affected services
ShipStation App
ShipStation Carrier FedEx
ShipStation Carrier UPS
Resolved
Jul 25, 2025 at 06:35pm UTC
ShipStation Carrier UPS recovered.
Affected services
Updated
Jul 25, 2025 at 04:51pm UTC
ShipStation App and ShipStation Carrier FedEx recovered.
Affected services
Updated
Jul 25, 2025 at 04:47pm UTC
ShipStation App and ShipStation Carrier FedEx are degraded.
Affected services
Created
Jul 25, 2025 at 04:38pm UTC
ShipStation Carrier UPS is degraded.
Affected services