Back to overview
Degraded

ShipStation Carrier UPS is down

Jun 10, 2025 at 01:32pm UTC
Affected services
ShipStation Carrier UPS

Resolved
Jun 10, 2025 at 01:36pm UTC

ShipStation Carrier UPS recovered.

Created
Jun 10, 2025 at 01:32pm UTC

ShipStation Carrier UPS is degraded.